Posts Tagged ‘Feed’

Updated To WordPress 2.0.6 And FeedBurner Fix

Posted on January 2007 at about 1:18 AM by hwa

Just updated my WordPress to the latest version, WordPress 2.0.6, and also applied the FeedBurner fix, where sometime FeedBurner will return an error telling that you have invalid xml, or an error message like below:

Your server disconnected us before sending the full source feed content. If your blogging platform is TextPattern, this is a known bug, and a fix can be found here: http://forum.textpattern.com/viewtopic.php?id=11247

Here’s an explanation from NeoSmart:

Explanation

FeedBurner uses something called “Conditional Get requests” to ask your server whether or not the page has changed since the last it viewed it, in order to save you some bandwidth. Depending on how popular your site is, FeedBurner may hit up your feed up to hundreds of times a day, so this is a really good idea! Unfortunately, in WordPress 2.0.6, your site doesn’t respond in a way that FeedBurner recognizes. The 304 headers it sends back to let it know that the content hasn’t changed are malformed and corrupt – and FeedBurner has no idea what they mean.

To fix this problems is easy, all you have to just open up your functions.php inside your wp-includes folder, go to line 2231, 2233 and 2234 and comment out this three lines, like below:

  1. ...
  2. //if ( substr(php_sapi_name(), 0, 3) == 'cgi' )
  3.     @header("HTTP/1.1 $header $text");
  4. //else
  5.     //@header("Status: $header $text");
  6. ...

That should fix your feed problem, there are a few more solutions from Mark Jaquith and NeoSmart, head over to their blog and find the one suit you most! 🙂